in Hacks

Three Tips To Get VMware Workstation 9 Going on Kernel 3.8.0

First off, if you are trying to get VMware Workstation 9.x to run on a non-supported system or one that really hasn’t even been formally released yet like Ubuntu 13.04 “Raring Ringtail” you need to stop and ask yourself a few questions…

  • Do you want the drama?
  • Can you handle the bleeding edge and constant updates through the Ubuntu daily channel that will generate havoc on your computer?
  • Why can’t you just be normal and stay on supported versions of Linux?
  • What is wrong with you?

Good. If you’re still with me, then here are some tricks to try and get you over some bumps with getting VMware Workstation 9 to run on Ubuntu 13.04 and the 3.8.0-x kernels.

1. If you get the VMware Kernel Mod screen.

vmwarekernelmodupdater-3.8x

Try doing a symlink to the changed location of the version.h file to a spot where vmware is looking for it. In my case with kernel 3.8.0-12-generic it was located in

But vmware is looking for the version.h file in under <kernelsource path>/include/linux/version.h so, you giving it a symlink might get you past it.

Doing this then trying to run vmware-workstation from the terminal or via a GUI launcher should get you past the Module Updater prompt.

2. If you are still getting kernel module issues after install. Try installing the open vm-tools for your distro. For Ubuntu 13.04, they look like this in Synaptic. Get them all.

vmtoolsinstall

3. You can start VMware Workstation 9.0.x but you are unable to enter your license code through the GUI. This is annoying.

vmware-licensekeynogo

It looks like it will fire-up to allow you to enter your license key, but it doesn’t. Good news is you can do it via terminal. Close out of vmware-workstation and run this.

with the xxxx being your valid license key. This will get the key into the config properly without having to try and game the busted GUI.

4. Always, always check to make sure you get the latest and greatest version of vmware-workstation. As of this post, the current was VMware Workstation 9.0.2 and it came out about a week ago. They do updates to get you in the ballpark of issues, but they are generally always behind the churn of Linux kernels. They also tuck the download URL behind a login which is a pain.

vmwarework902

Hope this helps. VMware eventually gets stuff going well, you just typically need to stay a bit behind on kernel and distro versions which is fine for the “normal” people out there. All bets are off if you are crazy like many Linux folks though.

vmwarerunning

 

Write a Comment

Comment

twenty + twenty =

21 Comments

  1. Thanks for taking the time to figure out the workarounds with this! It’s always a pain when we get a big change in the kernel, and unfortunately VMware seems more concerned with getting the Windows side of things working first. I still think their products are awesome though, so I use them anyway.
    I’ll definitely be referencing your article towards the end of April when Kubuntu gets finished with beta testing.

  2. hi jonathan,
    running ubuntu 13.04 and VMWwkstn 9.0.2
    am facing the issue of license-button being disabled. tried to manually apply the license key, but receive the error:
    bash: usr/lib/vmware/bin/vmware-vmx-debug: No such file or directory
    even though file exists. also tried with sudo.
    appreciate your guidance on this, thx!

  3. Thanks for posting this. It was very helpful. I will still on vmware workstation 8 but I had an update code for 9. Once on 9 and following your directions it was a snap to get working again after the upgrade.

    I must say that Ubuntu LTS 12 was nothing but junk for me. I ended up going to 13 hoping to fix the display issues I was having with menus not working on the menu bar. I admit this notebook has been through 3 or 4 major updates without a fresh install so that may have something to do with the issues I was seeing.

    • Great to hear. I agree with you on 12. I run Ubuntu natively on my Macbook Pro 8,2 and it ran better than OSX, but that is not saying much. I jumped on 13 early and was glad I did.

  4. Thanks, It stopped the asking of the location for the kernel location. The only thing is, it says:
    “Before you can VMware, several modules must be compiled and loaded into the running kernel.”

    Which modules do you think it could be talking about? (Linux Mint 15, linux kernel 3.8.0-19)

  5. Some module compiling problems have been fixed in VMware Workstation 9.0.2. However, I had a lot of trouble updating to that version. Here’s what worked for me.

    First, the “VMware Kernel Module Updater” kept me from starting VMware and accessing the auto-update functionality. I got past it by editing the file /etc/vmware/config. In the following two lines,

    VMCI_CONFED = “yes”
    VSOCK_CONFED = “yes”

    change each “yes” to “no”.

    After that, clear your /tmp directory. Then launch VMware and allow it to auto-update. After downloading VMware Workstation 9.0.2, the updater will give you an error message. However, at this point the 9.0.2 installer has already been downloaded and is in your drive!

    The largest file in /tmp (that’s why I suggested clearing it) is the VMware Workstation 9.0.2 installer in a tar archive. Extract the archive with any program. Finally, mark the installer as executable and run it as root.

    The installer will change the file /etc/vmware/config back, so you don’t need to undo your changes to it.

    • Excellent. Thanks. I recently went to Ubuntu 13.10 Saucy and 3.9.x without any issues so far but is is helpful to know if I do hit something. Thanks!

  6. +1 on this. Mergy, I tried a number of other fixes suggested elsewhere, but only the open-vmtools install did the trick. Great brief write-up here! If I found this site first, it would have saved me several hours. Thank you!

    Configuration: Mint 15, Workstation 9.0

    Of course, now I need to explore issues updating to 9.0.2 :-) but at least I’m up and running again!

  7. Oh man, thank you so much for this! I have been literally tearing my hair out and then I found your page. My issue was with entering the license but thanks to your trick in the terminal, it has been sorted and finally works.

    This man deserves a BIG drink!

  8. Please could you help, I have read this thread and still having issues with compiling. as root running vmware in terminal I get this:
    Stopping VMware services:
    VMware Authentication Daemon done
    VM communication interface socket family done
    Virtual machine communication interface done
    Virtual machine monitor done
    Blocking file system done

    and then the vmware kernel module updater window shows up and at this point the installer just sits there for a while then another error window appears with Unable to stop services see log file for details and this is the content of the log file:

    2013-08-07T17:25:07.049-08:00| appLoader| I120: Log for VMware Workstation pid=23621 version=9.0.0 build=build-812388 option=Release
    2013-08-07T17:25:07.049-08:00| appLoader| I120: The process is 64-bit.
    2013-08-07T17:25:07.049-08:00| appLoader| I120: Host codepage=UTF-8 encoding=UTF-8
    2013-08-07T17:25:07.049-08:00| appLoader| I120: Host is Linux 3.8.0-27-generic Ubuntu 13.04
    2013-08-07T17:25:07.192-08:00| appLoader| I120: Invocation: “/usr/lib/vmware/bin/vmware-modconfig –launcher=/usr/bin/vmware-modconfig –appname=VMware Workstation –icon=vmware-workstation”
    2013-08-07T17:25:07.192-08:00| appLoader| I120: Calling: “/usr/lib/vmware/bin/vmware-modconfig –launcher=/usr/bin/vmware-modconfig –appname=VMware Workstation –icon=vmware-workstation”
    2013-08-07T17:25:07.192-08:00| appLoader| I120: VMDEVEL not set.
    2013-08-07T17:25:07.192-08:00| appLoader| I120: VMWARE_SHIPPED_LIBS_LIST is not set.
    2013-08-07T17:25:07.192-08:00| appLoader| I120: VMWARE_SYSTEM_LIBS_LIST is not set.
    2013-08-07T17:25:07.192-08:00| appLoader| I120: VMWARE_USE_SHIPPED_LIBS is not set.
    2013-08-07T17:25:07.192-08:00| appLoader| I120: VMWARE_USE_SYSTEM_LIBS is not set.
    2013-08-07T17:25:07.192-08:00| appLoader| I120: Using configuration file /etc/vmware/config.
    2013-08-07T17:25:07.201-08:00| appLoader| I120: Using library directory: /usr/lib/vmware.
    2013-08-07T17:25:07.234-08:00| appLoader| I120: Shipped glib version is 2.24
    2013-08-07T17:25:07.234-08:00| appLoader| I120: System glib version is 2.36
    2013-08-07T17:25:07.234-08:00| appLoader| I120: Using system version of glib.
    2013-08-07T17:25:07.234-08:00| appLoader| I120: Detected VMware library libvmware-modconfig.so.
    2013-08-07T17:25:07.234-08:00| appLoader| I120: Marking libvmware-modconfig.so node as SHIPPED.
    2013-08-07T17:25:07.282-08:00| appLoader| I120: Marking libgcc_s.so.1 node as INVALID.
    2013-08-07T17:25:07.282-08:00| appLoader| I120: Marking libsexy.so.2 node as INVALID.
    2013-08-07T17:25:07.283-08:00| appLoader| I120: Marking libsexymm.so.2 node as INVALID.
    2013-08-07T17:25:07.283-08:00| appLoader| I120: Detected VMware library libvmwarebase.so.0.
    2013-08-07T17:25:07.283-08:00| appLoader| I120: Marking libvmwarebase.so.0 node as SHIPPED.
    2013-08-07T17:25:07.283-08:00| appLoader| I120: Marking libgvmomi.so.0 node as INVALID.
    2013-08-07T17:25:07.284-08:00| appLoader| I120: Marking libcds.so node as INVALID.
    2013-08-07T17:25:07.284-08:00| appLoader| I120: Detected VMware library libvmwareui.so.0.
    2013-08-07T17:25:07.284-08:00| appLoader| I120: Marking libvmwareui.so.0 node as SHIPPED.
    2013-08-07T17:25:07.284-08:00| appLoader| I120: Marking libpng12.so.0 node as INVALID.
    2013-08-07T17:25:07.290-08:00| appLoader| I120: Marking libcairomm-1.0.so.1 node as INVALID.
    2013-08-07T17:25:07.300-08:00| appLoader| I120: Marking libcairo.so.2 node as INVALID.
    2013-08-07T17:25:07.308-08:00| appLoader| I120: Marking libpangocairo-1.0.so.0 node as INVALID.
    2013-08-07T17:25:07.308-08:00| appLoader| I120: Marking libpixman-1.so.0 node as INVALID.
    2013-08-07T17:25:07.308-08:00| appLoader| I120: Marking libXfixes.so.3 node as INVALID.
    2013-08-07T17:25:07.316-08:00| appLoader| I120: Marking libXdmcp.so.6 node as INVALID.
    2013-08-07T17:25:07.317-08:00| appLoader| I120: Marking libz.so.1 node as INVALID.
    2013-08-07T17:25:07.317-08:00| appLoader| I120: Marking libview.so.3 node as INVALID.
    2013-08-07T17:25:07.318-08:00| appLoader| I120: Marking librsvg-2.so.2 node as INVALID.
    2013-08-07T17:25:07.321-08:00| appLoader| I120: Marking libxml2.so.2 node as INVALID.
    2013-08-07T17:25:07.322-08:00| appLoader| I120: Marking libart_lgpl_2.so.2 node as INVALID.
    2013-08-07T17:25:07.322-08:00| appLoader| I120: Marking libgtkmm-2.4.so.1 node as INVALID.
    2013-08-07T17:25:07.326-08:00| appLoader| I120: Marking libgdkmm-2.4.so.1 node as INVALID.
    2013-08-07T17:25:07.327-08:00| appLoader| I120: Marking libpangomm-1.4.so.1 node as INVALID.
    2013-08-07T17:25:07.327-08:00| appLoader| I120: Marking libatkmm-1.6.so.1 node as INVALID.
    2013-08-07T17:25:07.328-08:00| appLoader| I120: Marking libglibmm_generate_extra_defs-2.4.so.1 node as INVALID.
    2013-08-07T17:25:07.328-08:00| appLoader| I120: Marking libglibmm-2.4.so.1 node as INVALID.
    2013-08-07T17:25:07.328-08:00| appLoader| I120: Marking libgiomm-2.4.so.1 node as INVALID.
    2013-08-07T17:25:07.355-08:00| appLoader| I120: Marking libsigc-2.0.so.0 node as INVALID.
    2013-08-07T17:25:07.363-08:00| appLoader| I120: Marking libgtk-x11-2.0.so.0 node as INVALID.
    2013-08-07T17:25:07.364-08:00| appLoader| I120: Marking libgdk_pixbuf-2.0.so.0 node as INVALID.
    2013-08-07T17:25:07.364-08:00| appLoader| I120: Marking libgdk-x11-2.0.so.0 node as INVALID.
    2013-08-07T17:25:07.364-08:00| appLoader| I120: Marking libpangox-1.0.so.0 node as INVALID.
    2013-08-07T17:25:07.369-08:00| appLoader| I120: Marking libpangoxft-1.0.so.0 node as INVALID.
    2013-08-07T17:25:07.370-08:00| appLoader| I120: Marking libpangoft2-1.0.so.0 node as INVALID.
    2013-08-07T17:25:07.371-08:00| appLoader| I120: Marking libpango-1.0.so.0 node as INVALID.
    2013-08-07T17:25:07.371-08:00| appLoader| I120: Marking libatk-1.0.so.0 node as INVALID.
    2013-08-07T17:25:07.371-08:00| appLoader| I120: Marking libgthread-2.0.so.0 node as INVALID.
    2013-08-07T17:25:07.372-08:00| appLoader| I120: Marking libgobject-2.0.so.0 node as INVALID.
    2013-08-07T17:25:07.372-08:00| appLoader| I120: Marking libgmodule-2.0.so.0 node as INVALID.
    2013-08-07T17:25:07.372-08:00| appLoader| I120: Marking libglib-2.0.so.0 node as INVALID.
    2013-08-07T17:25:07.372-08:00| appLoader| I120: Marking libgio-2.0.so.0 node as INVALID.
    2013-08-07T17:25:07.373-08:00| appLoader| I120: Marking libgcrypt.so.11 node as INVALID.
    2013-08-07T17:25:07.373-08:00| appLoader| I120: Marking libgpg-error.so.0 node as INVALID.
    2013-08-07T17:25:07.373-08:00| appLoader| I120: Marking libgcr.so.0 node as INVALID.
    2013-08-07T17:25:07.374-08:00| appLoader| I120: Marking libgck.so.0 node as INVALID.
    2013-08-07T17:25:07.374-08:00| appLoader| I120: Marking libXft.so.2 node as INVALID.
    2013-08-07T17:25:07.374-08:00| appLoader| I120: Marking libXrender.so.1 node as INVALID.
    2013-08-07T17:25:07.375-08:00| appLoader| I120: Marking libfreetype.so.6 node as INVALID.
    2013-08-07T17:25:07.375-08:00| appLoader| I120: Marking libfontconfig.so.1 node as INVALID.
    2013-08-07T17:25:07.375-08:00| appLoader| I120: Marking libexpat.so.0 node as INVALID.
    2013-08-07T17:25:07.375-08:00| appLoader| I120: Marking libXrandr.so.2 node as INVALID.
    2013-08-07T17:25:07.376-08:00| appLoader| I120: Marking libXcursor.so.1 node as INVALID.
    2013-08-07T17:25:07.376-08:00| appLoader| I120: Marking libXau.so.6 node as INVALID.
    2013-08-07T17:25:07.376-08:00| appLoader| I120: Marking libXinerama.so.1 node as INVALID.
    2013-08-07T17:25:07.377-08:00| appLoader| I120: Marking libstdc++.so.6 node as INVALID.
    2013-08-07T17:25:07.584-08:00| appLoader| I120: Marking libXdamage.so.1 node as INVALID.
    2013-08-07T17:25:07.585-08:00| appLoader| I120: Marking libXcomposite.so.1 node as INVALID.
    2013-08-07T17:25:08.031-08:00| appLoader| I120: Marking libcurl.so.4 node as INVALID.
    2013-08-07T17:25:08.040-08:00| appLoader| I120: Marking libglade-2.0.so.0 node as INVALID.
    2013-08-07T17:25:08.347-08:00| appLoader| I120: Marking libcrypto.so.0.9.8 node as INVALID.
    2013-08-07T17:25:08.348-08:00| appLoader| I120: Marking libssl.so.0.9.8 node as INVALID.
    2013-08-07T17:25:08.500-08:00| appLoader| I120: Created dependency tree.
    2013-08-07T17:25:08.500-08:00| appLoader| I120: — Processing libgtkmm-2.4.so.1 —
    2013-08-07T17:25:08.768-08:00| appLoader| I120: libgtkmm-2.4.so.1 validator returned true.
    2013-08-07T17:25:08.768-08:00| appLoader| I120: Marking libgtkmm-2.4.so.1 node as SYSTEM.
    2013-08-07T17:25:08.768-08:00| appLoader| I120: — Finished processing libgtkmm-2.4.so.1 —
    2013-08-07T17:25:08.853-08:00| appLoader| I120: Accessibility is not enabled.
    2013-08-07T17:25:08.861-08:00| appLoader| I120: Accessibility is not enabled.
    2013-08-07T17:25:08.861-08:00| appLoader| I120: — Processing libgtk-x11-2.0.so.0 —
    2013-08-07T17:25:08.869-08:00| appLoader| I120: GTK: gtk_major_version: Comparing 2 with 2
    2013-08-07T17:25:08.869-08:00| appLoader| I120: GTK: gtk_minor_version: Comparing 24 with 20
    2013-08-07T17:25:08.869-08:00| appLoader| I120: libgtk-x11-2.0.so.0 validator returned true.
    2013-08-07T17:25:08.869-08:00| appLoader| I120: Marking libgtk-x11-2.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.869-08:00| appLoader| I120: — Finished processing libgtk-x11-2.0.so.0 —
    2013-08-07T17:25:08.869-08:00| appLoader| I120: — Processing libglib-2.0.so.0 —
    2013-08-07T17:25:08.869-08:00| appLoader| I120: GLib: glib_major_version: Comparing 2 with 2
    2013-08-07T17:25:08.869-08:00| appLoader| I120: GLib: glib_minor_version: Comparing 36 with 36
    2013-08-07T17:25:08.869-08:00| appLoader| I120: libglib-2.0.so.0 validator returned true.
    2013-08-07T17:25:08.869-08:00| appLoader| I120: Marking libglib-2.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.869-08:00| appLoader| I120: — Finished processing libglib-2.0.so.0 —
    2013-08-07T17:25:08.869-08:00| appLoader| I120: Marking libstdc++.so.6 node as SYSTEM.
    2013-08-07T17:25:08.869-08:00| appLoader| I120: Marking libgcc_s.so.1 node as SYSTEM.
    2013-08-07T17:25:08.869-08:00| appLoader| I120: Marking libXinerama.so.1 node as SYSTEM.
    2013-08-07T17:25:08.869-08:00| appLoader| I120: Marking libXau.so.6 node as SYSTEM.
    2013-08-07T17:25:08.869-08:00| appLoader| I120: Marking libXcursor.so.1 node as SYSTEM.
    2013-08-07T17:25:08.869-08:00| appLoader| I120: Marking libXrender.so.1 node as SYSTEM.
    2013-08-07T17:25:08.869-08:00| appLoader| I120: Marking libXfixes.so.3 node as SYSTEM.
    2013-08-07T17:25:08.869-08:00| appLoader| I120: Marking libXrandr.so.2 node as SYSTEM.
    2013-08-07T17:25:08.869-08:00| appLoader| I120: Marking libexpat.so.0 node as SHIPPED.
    2013-08-07T17:25:08.869-08:00| appLoader| I120: Marking libfontconfig.so.1 node as SYSTEM.
    2013-08-07T17:25:08.869-08:00| appLoader| I120: Marking libfreetype.so.6 node as SYSTEM.
    2013-08-07T17:25:08.869-08:00| appLoader| I120: Marking libz.so.1 node as SYSTEM.
    2013-08-07T17:25:08.894-08:00| appLoader| I120: Marking libXft.so.2 node as SYSTEM.
    2013-08-07T17:25:08.894-08:00| appLoader| I120: Marking libgck.so.0 node as SHIPPED.
    2013-08-07T17:25:08.895-08:00| appLoader| I120: Marking libgio-2.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.895-08:00| appLoader| I120: Marking libgobject-2.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.895-08:00| appLoader| I120: Marking libgthread-2.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.895-08:00| appLoader| I120: Marking libgmodule-2.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.895-08:00| appLoader| I120: Marking libgcr.so.0 node as SHIPPED.
    2013-08-07T17:25:08.895-08:00| appLoader| I120: Marking libgcrypt.so.11 node as SYSTEM.
    2013-08-07T17:25:08.895-08:00| appLoader| I120: Marking libgpg-error.so.0 node as SYSTEM.
    2013-08-07T17:25:08.895-08:00| appLoader| I120: Marking libgdk-x11-2.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.896-08:00| appLoader| I120: Marking libpangocairo-1.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.896-08:00| appLoader| I120: Marking libcairo.so.2 node as SYSTEM.
    2013-08-07T17:25:08.896-08:00| appLoader| I120: Marking libpixman-1.so.0 node as SYSTEM.
    2013-08-07T17:25:08.896-08:00| appLoader| I120: Marking libpng12.so.0 node as SYSTEM.
    2013-08-07T17:25:08.896-08:00| appLoader| I120: Marking libpangoft2-1.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.896-08:00| appLoader| I120: Marking libpango-1.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.896-08:00| appLoader| I120: Marking libXcomposite.so.1 node as SYSTEM.
    2013-08-07T17:25:08.896-08:00| appLoader| I120: Marking libXdamage.so.1 node as SYSTEM.
    2013-08-07T17:25:08.896-08:00| appLoader| I120: Marking libgdk_pixbuf-2.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.896-08:00| appLoader| I120: Marking libatk-1.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.907-08:00| appLoader| I120: Marking libpangoxft-1.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.915-08:00| appLoader| I120: Marking libpangox-1.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.915-08:00| appLoader| I120: Marking libsigc-2.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.915-08:00| appLoader| I120: Marking libgiomm-2.4.so.1 node as SYSTEM.
    2013-08-07T17:25:08.915-08:00| appLoader| I120: Marking libglibmm-2.4.so.1 node as SYSTEM.
    2013-08-07T17:25:08.921-08:00| appLoader| I120: Marking libglibmm_generate_extra_defs-2.4.so.1 node as SYSTEM.
    2013-08-07T17:25:08.921-08:00| appLoader| I120: Marking libatkmm-1.6.so.1 node as SYSTEM.
    2013-08-07T17:25:08.921-08:00| appLoader| I120: Marking libpangomm-1.4.so.1 node as SYSTEM.
    2013-08-07T17:25:08.921-08:00| appLoader| I120: Marking libcairomm-1.0.so.1 node as SYSTEM.
    2013-08-07T17:25:08.922-08:00| appLoader| I120: Marking libgdkmm-2.4.so.1 node as SYSTEM.
    2013-08-07T17:25:08.934-08:00| appLoader| I120: Marking libart_lgpl_2.so.2 node as SYSTEM.
    2013-08-07T17:25:08.935-08:00| appLoader| I120: Marking libxml2.so.2 node as SHIPPED.
    2013-08-07T17:25:08.971-08:00| appLoader| I120: Marking librsvg-2.so.2 node as SYSTEM.
    2013-08-07T17:25:08.971-08:00| appLoader| I120: Marking libview.so.3 node as SHIPPED.
    2013-08-07T17:25:08.972-08:00| appLoader| I120: Marking libXdmcp.so.6 node as SYSTEM.
    2013-08-07T17:25:08.984-08:00| appLoader| I120: Marking libglade-2.0.so.0 node as SYSTEM.
    2013-08-07T17:25:08.984-08:00| appLoader| I120: Marking libsexy.so.2 node as SHIPPED.
    2013-08-07T17:25:08.984-08:00| appLoader| I120: Marking libsexymm.so.2 node as SHIPPED.
    2013-08-07T17:25:08.984-08:00| appLoader| I120: Marking libgvmomi.so.0 node as SHIPPED.
    2013-08-07T17:25:09.087-08:00| appLoader| I120: System libcurl.so.4 has version 7.29.0 (need 7.19.5) and has NOT been compiled with c-ares support.
    2013-08-07T17:25:09.087-08:00| appLoader| I120: Marking libcurl.so.4 node as SHIPPED.
    2013-08-07T17:25:09.146-08:00| appLoader| I120: Marking libssl.so.0.9.8 node as SHIPPED.
    2013-08-07T17:25:09.146-08:00| appLoader| I120: Marking libcrypto.so.0.9.8 node as SHIPPED.
    2013-08-07T17:25:09.146-08:00| appLoader| I120: Marking libcds.so node as SHIPPED.
    2013-08-07T17:25:09.146-08:00| appLoader| I120: Marking libsexy.so.2 node as SHIPPED.
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libXinerama.so.1
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libXrandr.so.2
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libview.so.3
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libsexymm.so.2
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libatkmm-1.6.so.1
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libatk-1.0.so.0
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libpangomm-1.4.so.1
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libXfixes.so.3
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libpixman-1.so.0
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libcds.so
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libgcr.so.0
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libglib-2.0.so.0
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libgcc_s.so.1
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libXft.so.2
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libgck.so.0
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libcairo.so.2
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libgio-2.0.so.0
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libXcursor.so.1
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libz.so.1
    2013-08-07T17:25:09.146-08:00| appLoader| I120: libgtk-x11-2.0.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libXcomposite.so.1
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libgiomm-2.4.so.1
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libgdkmm-2.4.so.1
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libglade-2.0.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libexpat.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libpangox-1.0.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libcurl.so.4
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libsigc-2.0.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libgdk_pixbuf-2.0.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libpng12.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libpangoft2-1.0.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libXau.so.6
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libpangoxft-1.0.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libgobject-2.0.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libvmware-modconfig.so
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libglibmm-2.4.so.1
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libpango-1.0.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libgpg-error.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libfreetype.so.6
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libssl.so.0.9.8
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libvmwarebase.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libgvmomi.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libsexy.so.2
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libcrypto.so.0.9.8
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libgmodule-2.0.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libart_lgpl_2.so.2
    2013-08-07T17:25:09.147-08:00| appLoader| I120: librsvg-2.so.2
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libpangocairo-1.0.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libvmwareui.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libgcrypt.so.11
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libgdk-x11-2.0.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libstdc++.so.6
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libgtkmm-2.4.so.1
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libfontconfig.so.1
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libglibmm_generate_extra_defs-2.4.so.1
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libXdmcp.so.6
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libXdamage.so.1
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libXrender.so.1
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libxml2.so.2
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libgthread-2.0.so.0
    2013-08-07T17:25:09.147-08:00| appLoader| I120: libcairomm-1.0.so.1
    2013-08-07T17:25:09.151-08:00| appLoader| I120: Shipped glib version is 2.24
    2013-08-07T17:25:09.151-08:00| appLoader| I120: System glib version is 2.36
    2013-08-07T17:25:09.151-08:00| appLoader| I120: Using system version of glib.
    2013-08-07T17:25:09.151-08:00| appLoader| I120: Loading shipped version of libcrypto.so.0.9.8.
    2013-08-07T17:25:09.176-08:00| appLoader| I120: Loading shipped version of libssl.so.0.9.8.
    2013-08-07T17:25:09.187-08:00| appLoader| I120: Loading system version of libXinerama.so.1.
    2013-08-07T17:25:09.188-08:00| appLoader| I120: Loading system version of libXrandr.so.2.
    2013-08-07T17:25:09.188-08:00| appLoader| I120: Loading system version of libatkmm-1.6.so.1.
    2013-08-07T17:25:09.191-08:00| appLoader| I120: Loading system version of libatk-1.0.so.0.
    2013-08-07T17:25:09.191-08:00| appLoader| I120: Loading system version of libpangomm-1.4.so.1.
    2013-08-07T17:25:09.193-08:00| appLoader| I120: Loading system version of libXfixes.so.3.
    2013-08-07T17:25:09.193-08:00| appLoader| I120: Loading system version of libpixman-1.so.0.
    2013-08-07T17:25:09.193-08:00| appLoader| I120: Loading system version of libglib-2.0.so.0.
    2013-08-07T17:25:09.193-08:00| appLoader| I120: Loading system version of libgcc_s.so.1.
    2013-08-07T17:25:09.193-08:00| appLoader| I120: Loading system version of libXft.so.2.
    2013-08-07T17:25:09.194-08:00| appLoader| I120: Loading system version of libcairo.so.2.
    2013-08-07T17:25:09.194-08:00| appLoader| I120: Loading system version of libgio-2.0.so.0.
    2013-08-07T17:25:09.194-08:00| appLoader| I120: Loading system version of libXcursor.so.1.
    2013-08-07T17:25:09.194-08:00| appLoader| I120: Loading system version of libz.so.1.
    2013-08-07T17:25:09.194-08:00| appLoader| I120: Loading system version of libgtk-x11-2.0.so.0.
    2013-08-07T17:25:09.195-08:00| appLoader| I120: Loading system version of libXcomposite.so.1.
    2013-08-07T17:25:09.195-08:00| appLoader| I120: Loading system version of libgiomm-2.4.so.1.
    2013-08-07T17:25:09.198-08:00| appLoader| I120: Loading system version of libgdkmm-2.4.so.1.
    2013-08-07T17:25:09.199-08:00| appLoader| I120: Loading system version of libglade-2.0.so.0.
    2013-08-07T17:25:09.200-08:00| appLoader| I120: Loading system version of libpangox-1.0.so.0.
    2013-08-07T17:25:09.200-08:00| appLoader| I120: Loading system version of libsigc-2.0.so.0.
    2013-08-07T17:25:09.200-08:00| appLoader| I120: Loading system version of libgdk_pixbuf-2.0.so.0.
    2013-08-07T17:25:09.200-08:00| appLoader| I120: Loading system version of libpng12.so.0.
    2013-08-07T17:25:09.200-08:00| appLoader| I120: Loading system version of libpangoft2-1.0.so.0.
    2013-08-07T17:25:09.200-08:00| appLoader| I120: Loading system version of libXau.so.6.
    2013-08-07T17:25:09.200-08:00| appLoader| I120: Loading system version of libpangoxft-1.0.so.0.
    2013-08-07T17:25:09.200-08:00| appLoader| I120: Loading system version of libgobject-2.0.so.0.
    2013-08-07T17:25:09.200-08:00| appLoader| I120: Loading system version of libglibmm-2.4.so.1.
    2013-08-07T17:25:09.200-08:00| appLoader| I120: Loading system version of libpango-1.0.so.0.
    2013-08-07T17:25:09.200-08:00| appLoader| I120: Loading system version of libgpg-error.so.0.
    2013-08-07T17:25:09.200-08:00| appLoader| I120: Loading system version of libfreetype.so.6.
    2013-08-07T17:25:09.200-08:00| appLoader| I120: Loading system version of libgmodule-2.0.so.0.
    2013-08-07T17:25:09.200-08:00| appLoader| I120: Loading system version of libart_lgpl_2.so.2.
    2013-08-07T17:25:09.200-08:00| appLoader| I120: Loading system version of librsvg-2.so.2.
    2013-08-07T17:25:09.201-08:00| appLoader| I120: Loading system version of libpangocairo-1.0.so.0.
    2013-08-07T17:25:09.201-08:00| appLoader| I120: Loading system version of libgcrypt.so.11.
    2013-08-07T17:25:09.201-08:00| appLoader| I120: Loading system version of libgdk-x11-2.0.so.0.
    2013-08-07T17:25:09.201-08:00| appLoader| I120: Loading system version of libstdc++.so.6.
    2013-08-07T17:25:09.201-08:00| appLoader| I120: Loading system version of libgtkmm-2.4.so.1.
    2013-08-07T17:25:09.210-08:00| appLoader| I120: Loading system version of libfontconfig.so.1.
    2013-08-07T17:25:09.210-08:00| appLoader| I120: Loading system version of libglibmm_generate_extra_defs-2.4.so.1.
    2013-08-07T17:25:09.210-08:00| appLoader| I120: Loading system version of libXdmcp.so.6.
    2013-08-07T17:25:09.210-08:00| appLoader| I120: Loading system version of libXdamage.so.1.
    2013-08-07T17:25:09.210-08:00| appLoader| I120: Loading system version of libXrender.so.1.
    2013-08-07T17:25:09.210-08:00| appLoader| I120: Loading system version of libgthread-2.0.so.0.
    2013-08-07T17:25:09.211-08:00| appLoader| I120: Loading system version of libcairomm-1.0.so.1.
    2013-08-07T17:25:09.211-08:00| appLoader| I120: Loading shipped version of libexpat.so.0.
    2013-08-07T17:25:09.211-08:00| appLoader| I120: Loading shipped version of libgck.so.0.
    2013-08-07T17:25:09.211-08:00| appLoader| I120: Loading shipped version of libgcr.so.0.
    2013-08-07T17:25:09.221-08:00| appLoader| I120: Loading shipped version of libxml2.so.2.
    2013-08-07T17:25:09.234-08:00| appLoader| I120: Loading shipped version of libview.so.3.
    2013-08-07T17:25:09.243-08:00| appLoader| I120: Loading shipped version of libsexy.so.2.
    2013-08-07T17:25:09.244-08:00| appLoader| I120: Loading shipped version of libsexymm.so.2.
    2013-08-07T17:25:09.245-08:00| appLoader| I120: Loading shipped version of libvmwarebase.so.0.
    2013-08-07T17:25:09.322-08:00| appLoader| I120: Loading shipped version of libcurl.so.4.
    2013-08-07T17:25:09.322-08:00| appLoader| I120: Loading shipped version of libgvmomi.so.0.
    2013-08-07T17:25:09.372-08:00| appLoader| I120: Loading shipped version of libcds.so.
    2013-08-07T17:25:09.373-08:00| appLoader| I120: Loading shipped version of libvmwareui.so.0.

  9. Thank you so much Jonathan! I just built a brand new development computer — my dream development computer with an SSD, a terabyte drive for storing extra images and 32gb of RAM to run as many images as I need. I went ahead without thinking and installed the latest Ubuntu and was thinking I’d have to start over until I came across your blog. You saved me a days work, thank you.