Gallery 3 Image Rebuild

Fixing issues with Gallery 2 Import to Gallery 3

http://gallery.menalto.com/

I have used Gallery for over 7 years or so now and really have found it incredibly valuable to have to share pictures with family and friends. I have migrated through many version updates and now that Gallery just released the flashy looking Gallery 3, I wanted to go ahead and move to that. We have a personal image collection of about 12,000 images or so in our gallery that we have been adding to over the many years and knew an upgrade to the new version 3 was going to be a challenge. I moved off version 1 a couple of years ago and was not really happy with version 2 and the various updates so that was another big reason I wanted to get the new GUI tools and look of the Gallery 3 environment.

To upgrade to Gallery 3, you need to really install 3 in a separate directory, create a new database in mysql and get that all squared-away first then enable the Gallery 2 import module and import your existing Gallery 2 setup and albums. This is a departure from previous updates in that you really need to get a clean parellel struture up and running then run the old environment through the import/scrubbing process. Documentation for this is sparse at the moment since Gallery 3 just really was formally released last week or so.

Anyway, so you do that and I what I did was get that all going by creating a mysql db for Gallery 3 data tables and ran the Gallery 3 installer, etc. and enabled the G2 Import, pointed the importer at the old G2 install path and watched as it grinded-away at the import of the 12k or so images. But, after the multiple hour import process was done, it was a mess in that I didn’t have thumbnails of images at the smallest or resized sizes. I checked the Gallery 3 Forum, but not much help yet. So, I thought, let’s just redo the setup and try the import again. I did and was really careful about permissions in the Apache directory where the new Gallery was going to be and everything, but still no dice. I did notice that when I click through down to the full-sized image, it was present – it was just the the small thumbnail and resized thumbnails were hosed (not present).

At the unix-level, going into the new location where G3 wants to put albums – now in (GalleryDirectory)/var BTW, I noticed for whatever reason there were no thumbnails in the album sub-folders. So, went into the Admin area and did all the Maintenance stuff, but no dice either. The generic ‘Fix’ option that goes through the various low-level checks was no help. Also, the ‘Rebuild Images’ came back with zero images for whatever reason.

I was able to get to a solution by kicking-off a rebuild through the Theme Options under the Admin>Appearance menu. If you do that and change your ‘Thumbnail Size’ and ‘Resized Image’ size, it wants to kick-off a total rebuild for out-of-date files. You will get a prompt at the top of the browser window to have the rebuild go. Even if the values are correct, I changed them to a different value, let the rebuild run and then changed them back and let it run again.

Gallery 3 Theme Options Modified

Gallery 3 Image Rebuild

After making the Theme Options changes and kicking off the rebuild you have to sit for a while and it grinds but after, you will get your thumbnails and resized images back. This is something to try in case you make the plunge and your Gallery 2 Import to Gallery 3 doesn’t fully take. I am sure later versions will check for this, but for now it is a workaround.